processing yardım
  • Arkadaşlar merhabalar ben arduino ya yeni merak saldım aldım ve bir proje üzerinde çalışıyorum projemde processing ile arduinoya usb den veri göndermem lazım fakat processing çalışırken
    WARNING: RXTX Version mismatch
    Jar version = RXTX-2.2pre1
    native lib Version = RXTX-2.2pre2

    böle bi hata veriyo ardından


    at java.net.DualStackPlainSocketImpl.connect0(Native Method)
    at
    java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:69)
    at
    java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:337)
    at
    java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:198)
    at
    java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:180)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:157)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:391)
    at java.net.Socket.connect(Socket.java:579)
    at java.net.Socket.connect(Socket.java:528)
    at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
    at sun.net.www.http.HttpClient.openServer(HttpClient.java:388)
    at sun.net.www.http.HttpClient.openServer(HttpClient.java:483)
    at sun.net.www.http.HttpClient.(HttpClient.java:213)
    at sun.net.www.http.HttpClient.New(HttpClient.java:300)
    at sun.net.www.http.HttpClient.New(HttpClient.java:316)
    at
    sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:992)
    at
    sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:928)
    at
    sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:846)
    at
    sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1296)
    at java.net.URL.openStream(URL.java:1035)
    at processing.app.UpdateCheck.readInt(UpdateCheck.java:131)
    at processing.app.UpdateCheck.updateCheck(UpdateCheck.java:93)
    at processing.app.UpdateCheck$1.run(UpdateCheck.java:63)
    at java.lang.Thread.run(Thread.java:722)


    ardında böle bişi yazıyo kırmızı yazılarla araştırdım fakat denilenleri yapmama rağmen sorun gitmedi yardımcı olursanı çok sevinirim
  • Merhaba,

    Bu hata genelde versiyon çakışmalarında ortaya çıkıyor. Processing IDE'sinin Arduino'yla uyuşmaması gibi hallerde ortaya çıkıyor. IDE versiyonunu değiştirerek yapmayı deneyin.
  • ahmet bey ilginize teşekkürler ben processin sitesinde ki hem windows kurdum hemde windows javayı kurdum hata gene dewam etti eski versiyon mu yüklemeliyim benim kurduğum 1.5.1?
  • tekrar merhabalar şimdi 1,2,1 kurdum denedim aynı hatayı verdi. ben aslında kodu netten hazır bulmuştum nette kodu veren kişi processing0154beta ile yapmış ben bu programı bulabilirsem çalışacak gibi gelio ama o sürümü nette bulamadım bulabilen olursa çok sevinirim
  • Merhaba,

    64-bit Windows 7 kullanıyorsunuz galiba? 1.5.1'i tekrar yükleyin, onun üzerinden aşağıdaki işlemleri yapın.

    http://rxtx.qbang.org/wiki/index.php/Download 'taki binary sütunundan rxtx-2.1-7-bins-r2.zip 'i indirin. İndirdiğiniz dosyanın içindeki rxtx-2.1-7-bins-r2 'ye gidin, oradaki RXTXcomm 'u C:\Program Files\processing-1.5.1\java\lib\ext 'e kopyalayın. Tekrar
    C:\Users\Downloads\rxtx-2.1-7-bins-r2.zip\rxtx-2.1-7-bins-r2\Windows\i368-mingw32 'ye gidin oradaki rxtxParallel.dll ve rxtxSerial.dll 'yi C:\Program Files\processing-1.5.1\java\bin 'e kopyalayın.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Açık kaynak kültürü gereği, çözdüğünüz problemlerin çözümlerini paylaşmayı lütfen unutmayın.