Arduino Bluetooth 4.0, HC-05, HC-06 Degilde HM-10
  • Bildigim kadariyla hc-06 ve hc-05 bluetooth 2.0 teknolojisini kullaniyor ve okudugum kadariyla bu teknoloji 2007 yilina ait

    aliexpress te bluetooth modulleri aratirken internette hic rast gelmedigim ama aliexpress te baya siparis edilmis bluetooth 4.0 modulu (HM-10) gordum ki okudugum kadariyla bu teknoloji de 2013 yilina ait

    https://eksisozluk.com/entry/46645983

    oncelikle bu teknoloji daha hizli, cekim kapasitesi daha fazla, daha az enerji tuketiyor

    ayrica aliexpress fiyati 8-10tl arasi hc-05 ve hc-06 ile hemen hemen ayni

    Peki neden hc-05, hc-06 kadar populer degil? hani aliexpress ustunde cok satilsa da bu modul ile yapilan projeler cok mu cok az. ayrica turkce kaynak sifir.

    Dusuncelerinizi merak ettim, bu yuzden topic actim.
  • BLE teknolojisi moduller yada 4.0 modullerle 2.0 arasında sadece protokol bazında farklılık var 4.0 olanlarda daha yeni chip set kullanıldığından ve kullanım amaçları nedeni ıle daha düşük güç tuketecek şekilde tasarlandılar. ble protokolunda bır çok iş için farklı mantıkta kanallar getırıldı okuma kanalı yazma kanalı hem oku hem yaz kanalı gibi yenılıkler var kullanacagınız moda gore de ayrı ayrı ayarlamalar yapmak zorundasınız ve bu kanal kullanımı da bır izin polıtıkasına bağlı bunu ble cihaz belirliyor. 2.0 da basit bir rx tx mantıgı varken 4.0 da bır cok kanal olabılır ve unlar bırbırne karışmadan yonetılebılır. uygulaması bıraz daha zor oldugundan yeterı kadar ornek yok. mesela iphone da bt var ama 2.0 modullere bağlanamazsın 4.0 modullerde ıse belirli protol kodlarına ızın verılıyor. samsung s4 de ıse 4.0 modemlere bağlanma sorunlu ve kullanamazsın ama 2.0 modullere takla bıle attırabılırsın. aslında tamamen pazarlama ve ıhtıyaç meselesi. 2007 model 2.0 ıle 2013 model 4.o protokol farkı dışında bır yenılık getırmıyor hangisi ile başarılı çalışıyorsanız onu seçeceksiniz. tedavulden kalkmadı yanı bu teknoloji ardık adı dual mode oldu ya 2.0 protolu seçersin yada ustunu seçersin. yada single mod kullanıcam dersen 4.0 kullanıyorsun demek ona gore davranan bır kod geliştirmen lazım. 4.0 da rx tx kolayca olmuyor mantıgı farklılaştırdılar.
  • Bu modülü aliexpressten satın aldım ..... telefonun bluetooth'unda BT05 olarak görünüyor yanıda da soru işareti var bağlantı sağlanmıyor şifre de sormuyor
  • biraz google da arama yapın ben de kullanmadım telefonun ozellıgınde de olması lazım
    şöyle bir ornek var belkı faydası olur
    http://fab.cba.mit.edu/classes/863.15/doc/tutorials/programming/bluetooth.html

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook

Tagged

Açık kaynak kültürü gereği, çözdüğünüz problemlerin çözümlerini paylaşmayı lütfen unutmayın.